This website is not affiliated with, sponsored by, or approved by SAP AG.

Problems starting WF in internal table loops

Business WorkFlow

Moderators: Snowy, thx4allthefish

Problems starting WF in internal table loops

Postby conquer » Fri Nov 29, 2002 12:57 pm

I have a program that collect severals Purchase Orders numbers into a internal table and launch, in a "loop at table" command, the event BUS2012.ReleaseStepCreate for each order in this loop.
The function module SWE_EVENT_CREATE is used to start de WF.
The problem is that sometimes the Workflow is not started for some items in the internal table.
Example: for a set of 10 purchase order numbers, only 3 is launched, the others not. In another time, all 20 items, in a set of 20, is launched correctly. In another moment, only 7 is launched, in a set of 8, and so on.

The logic is following:

Loop at table01.

zobject = 'BUS2012'.
zobjkey = table01-ebeln.
zevent = 'releaseStepCreated'.
CLEAR zapplicant.
zapplicant-otype = 'US'.
zapplicant-objid = sy-uname.

CALL FUNCTION 'SWE_EVENT_CREATE'
EXPORTING
objtype = zobject
objkey = zobjkey
event = zevent
creator = zapplicant
* TAKE_WORKITEM_REQUESTER = ' '
* start_with_delay = ' '
start_recfb_synchron = 'X'
NO_COMMIT_FOR_QUEUE = ' '
* DEBUG_FLAG = ' '
* NO_LOGGING = ' '
* IDENT =
IMPORTING
event_id = zeventid
* TABLES
* EVENT_CONTAINER = ZCONTAINER
EXCEPTIONS
objtype_not_found = 01.
* OTHERS = 2

COMMIT WORK.
ZRESULT = sy-subrc.

Endloop.


Does anyone knows what can be happening ?

Thanks
conquer
 
Posts: 29
Joined: Sun Oct 20, 2002 3:33 pm

Postby JayaKumarPM » Thu Dec 05, 2002 12:21 pm

Hi,,

If the workflow is not getting triggered for all items ,, you may have to check whether theres is any Check function module or receiver function module attached to the Event which is fired.

Bye,
Jayakumar
JayaKumarPM
 
Posts: 3
Joined: Tue Dec 03, 2002 8:39 am
Location: India

Re: Problems starting WF in internal table loops

Postby shrestharaju » Wed May 16, 2012 9:56 am

Hi Conquer,

This is a decade old question. You must have already resolved the issue. Can you please let me know how you resolved it.

I have the same issue now (for BUS2032).

Thanking you.
Raju
shrestharaju
 
Posts: 4
Joined: Wed Jan 12, 2011 9:31 am

Re: Problems starting WF in internal table loops

Postby Gothmog » Wed May 16, 2012 10:03 am

It is 10 years old - Conquer hasn't visited this site since 2003.
Please do not raise an old topic from its grave, start a new one for your specific problem.
Locked.
68 74 74 70 3a 2f 2f 74 69 6e 79 75 72 6c 2e 63 6f 6d 2f 62 64 6f 37 6d 77 67
Gothmog
 
Posts: 1942
Joined: Wed Sep 12, 2007 4:46 am
Location: Probably not home


Return to Business WorkFlow

Who is online

Users browsing this forum: No registered users and 0 guests





This website is not affiliated with, sponsored by, or approved by SAP AG.