Page 1 of 1

Shop Papers Not Printing for Certain Material-Resolved

PostPosted: Tue Apr 16, 2013 4:10 pm
by 3042517
I've got a strange problem that I'm hoping I can get some suggestions as to where else I can look.

When I create a process order for one specific material in a specific plant the shop papers don't print. The PRT status on the process order gets updated but no output is generated when I look in SP01. Other materials in this plant print fine.

If I create a process order for the same material in a different plant the shop papers print fine.

I've looked at all the process order print config and can't find anything that would make one material/plant combination print and another not.

Any suggestions on where else I can look? I'm stumped.

Thanks in advance,

Re: Shop Papers Not Printing for Certain Material

PostPosted: Wed Apr 17, 2013 7:48 am
by Sharpshooter
If you follow Process order --> Settings --> Print info from the menu, you will see the relevant data used to access the print control customising.
I have also seen custom print programs simply exit without printing based on certain logic (bad practise but possible nonetheless). Set a breakpoint in the print program to see if it is getting called. If not, your problem is likely customising, if yes, follow the program and see if it bails out before printing.

Dave

Re: Shop Papers Not Printing for Certain Material

PostPosted: Tue Apr 23, 2013 2:06 am
by JohnnyB
Hi

Has your problem been resolved? I agree with Sharpshooter. It could be that the print program does not find any "printable" objects and just exits (I remember seeing such bad practice even in SAPs own print programs... :shock: ) . E.g. check, whether the control key in your operations allows printing.

JohnnyB

Re: Shop Papers Not Printing for Certain Material-Resolved

PostPosted: Tue Apr 23, 2013 2:48 pm
by 3042517
I feel like a dumb A$$ but the problem was that the control key was not set to print,