This website is not affiliated with, sponsored by, or approved by SAP AG.

notif created from maint plan but contains no equipment

Logistics : PM and its sub-modules & SM

Moderators: Snowy, thx4allthefish, PJA

notif created from maint plan but contains no equipment

Postby vikasguptakota » Tue Oct 15, 2013 11:26 pm

Hello Sapfans
I have a scenario where notifications are created from maintenance plan. The maintenance plan scheduling is done using IP30. IP30 is called through a batch job on weekly basis.
The problem is - sometimes the notification is created without equipment and functional location. Please note "sometimes". Mostly all notifications contain equipment and functional location which (I think) come from the maintenance plan.
Question is - why this type of notification is created which does not contain equipment and functional location ??
vikasguptakota
 
Posts: 13
Joined: Tue Oct 15, 2013 11:21 pm

Re: notif created from maint plan but contains no equipment

Postby PJA » Wed Oct 16, 2013 1:30 am

vikasguptakota

You are correct, the equip/floc is derived from the maintenance item within the maintenance plan.

If this is not happening, then the most likely reasons are:
- The equip/floc have deletion flags set
- You are using a development in the order creation process
- An SAP bug
Pete A
www.pjas.com
PJA
 
Posts: 11383
Joined: Sun Jul 20, 2003 3:11 pm
Location: Deepest darkest Aberdeenshire

Re: notif created from maint plan but contains no equipment

Postby vikasguptakota » Wed Oct 16, 2013 6:49 am

Thanks PJA for showing interest in my question.

- I have checked, the Eqpt/Floc do not contain deletion flag.
- There is no development in the notification creation process, because if there was a development the same issue would have happened with other notifications generated from the same plan.
- Does it mean it is SAP bug?
vikasguptakota
 
Posts: 13
Joined: Tue Oct 15, 2013 11:21 pm

Re: notif created from maint plan but contains no equipment

Postby PJA » Wed Oct 16, 2013 7:46 am

Have the equip/floc been manually deleted from the notification - see the change log.
Pete A
www.pjas.com
PJA
 
Posts: 11383
Joined: Sun Jul 20, 2003 3:11 pm
Location: Deepest darkest Aberdeenshire

Re: notif created from maint plan but contains no equipment

Postby vikasguptakota » Wed Oct 16, 2013 8:07 am

No. That is not the case. The Change Log does not say so.
vikasguptakota
 
Posts: 13
Joined: Tue Oct 15, 2013 11:21 pm

Re: notif created from maint plan but contains no equipment

Postby PJA » Wed Oct 16, 2013 9:00 am

Is it repeatable i.e. manually create the next call from the plan.
Pete A
www.pjas.com
PJA
 
Posts: 11383
Joined: Sun Jul 20, 2003 3:11 pm
Location: Deepest darkest Aberdeenshire

Re: notif created from maint plan but contains no equipment

Postby vikasguptakota » Fri Aug 15, 2014 12:00 am

Issue resolved. The problem was that there was an error in one equipment. The Ship-to-party assigned to equipment was not extended to the equipment sales area. Because of this the program failed to create notification, and in the subsequent case the notification was created without equipment. After removing the erroneous ship-to-party from equipment, the issue was resolved.
Thanks all for your valuable help.
vikasguptakota
 
Posts: 13
Joined: Tue Oct 15, 2013 11:21 pm


Return to Logistics PM

Who is online

Users browsing this forum: No registered users and 5 guests





This website is not affiliated with, sponsored by, or approved by SAP AG.