This website is not affiliated with, sponsored by, or approved by SAP AG.

MEI1/MEI4 not working despite settings and prerequisites

Logistics : MM and its sub-modules (WM, IM, PO, LIS)

Moderators: Snowy, thx4allthefish, svetja, Ha Tran

MEI1/MEI4 not working despite settings and prerequisites

Postby bart jongen » Tue Jul 20, 2010 1:08 am

Dear,

I am experiencing difficulties once I try to perform MEI1/MEI4.
My case is I have created a PO today with a normal PB00 (from an Inforecord) and after I have created the PO (note the GR and IR have not yet been done) I have later today created a Condition RL01 (1%) with MEK1, for the Vendor, valid from 01.07.2010 until 31.12.9999.

Now I want to update the PO with this RL01 Condition.
Therefore I customized the following (based on input I gathered from this and other forums) IMG-activities within MM>Conditions>Automatic Document Adjustment:
1. Activate Change Pointer for Message Category CONDBI;
flagged CONDBI as active
2. Control Purchasing Document Adjustment;
Added the line:
30 RL01 Vendor Discount % 2 Pricing 44 Vendor

Now as I learn from the i(nfo)-button/Program Documentation in MEI1, besides the customizing and the fact that GR/IR must not be posted yet, I have to run RMEBEIN4/MEI4 first and from the forums I learned that I also first need to run MEI3 in case the Document index active-indicator (LFM1-BLIND) is not set in my Vendor master.

Since we have not/do not want to set this indicator, I first ran MEI3 with the following fields inputted:
• Save under version = 000
• Purchasing document = my test PO
• Automatic document adjustment = X
• Subsequent settlement = X
• Name of run = ‘test’
• New run? = X
• Termination date = 20.07.2010 (=Today)
• Termination time = 12:00

This goes presumibly well since I get the following message: Entries were created for 1 documents in the index.

Next I ran MEI4:
Flagged the following indicators:
• Purchasing documents
• Pricing Documents
• Flag processed change pointers for reorganization
• Flag all change pointers for reorganization
Set the Condition change date from = 01.07.2010 to 31.12.2010
Also, this goes presumibly well since I get the following message: Worklist generated successfully

Next I ran MEI1 and then the fun is over…
I inputted the following:
• Purchase Documents: my test PO
• Price Determination Type = New price determ. for changed price elements, adopt manual
• Manual selection of Worklist (Documents) to Be processed = X
• Delete worklist after processing = X
• Maximum Documents for Each Processing Step During Asynchronous Update = 1

Then, nothing happens since I get the following message:
No documents belonging to document category Purchase Order/Scheduling Agre adjusted
Message no. NI050
Diagnosis
You have not chosen any documents of category 'Purchase Order/Scheduling Agre' for processing.
Procedure
Please check your selections.

Can anybody tell me what I am doing wrong here and how I can get this thing working?
Thanks a whole lot in advance!
Kind regards,
Bart Jongen
Eindhoven, the Netherlands
bart jongen
 
Posts: 209
Joined: Mon Sep 12, 2005 3:26 am
Location: Eindhoven, The Netherlands

Re: MEI1/MEI4 not working despite settings and prerequisites

Postby sapnomad » Thu Mar 05, 2015 3:56 pm

I realize this is a few years old, but did you ever get this working? I'm running into the same issue with the last step.

Thanks, Vlad
sapnomad
 
Posts: 124
Joined: Mon Nov 25, 2002 1:04 pm
Location: Cambridge, MA


Return to Logistics MM

Who is online

Users browsing this forum: No registered users and 11 guests





loading...


This website is not affiliated with, sponsored by, or approved by SAP AG.