This website is not affiliated with, sponsored by, or approved by SAP AG.

Unable to load Java Class

All postings related to SAP XI

Moderators: Snowy, thx4allthefish

Unable to load Java Class

Postby ileola » Fri Jul 22, 2011 9:44 am

Running the CTC wizard as part of post installation steps for NW73 (PI)

get the ff error notification:
Error: Could not load Java class com.sap.ctc.util.pi.services.ExchangeProfileSetup. Check if the class is present in library/application sap.com/com.sap.xi.ctc.app and that all of the referenced classes are also reachable.
Step: Maintains exchange profile destination


when i try and log on to the exchange profile to check settings i get an error - java.lang.NoClassDefFoundError:

should i skip step and continue?


Server details
Web Dynpro Runtime vendor: 'sap.com', name: 'tc/wd/webdynpro', scV: 'sap.com', scN: 'WD-RUNTIME', location: 'SAP AG', counter: '7.3002.20110407124859.0000', R: '7.30', SP: '2', PL: '3', change number: '137968', codeline: NW730CORE_02_REL

J2EE Engine 7.30.3710.131540.20110321145304

Java VM SAP Java Server VM, version:6.1.026, vendor: SAP AG

Operating system HP-UX, version: B.11.31, architecture: ia64
ileola
 
Posts: 39
Joined: Tue Aug 12, 2003 4:51 am

Re: Unable to load Java Class

Postby FRCAS » Fri Jul 29, 2011 12:36 am

Hello,

I have exactly the same problem.

Did you find a solution to this issue?

Thanks.
FRCAS
 
Posts: 1
Joined: Fri Jul 29, 2011 12:33 am

Re: Unable to load Java Class

Postby Baz » Fri Jul 29, 2011 1:16 am

i have not installed PI7.3 yet....
But the exchangeProfile is fundamental to the process and must be available.

have you checked to see if the missing file is available in another part of the installation disks?
Baz

AsPiRiNg tUlY iDiOt Image

http://www.catb.org/~esr/faqs/smart-questions.html

Image

check out my Podcasts http://dj-baz.podomatic.com
Baz
 
Posts: 4736
Joined: Fri Nov 08, 2002 5:54 am
Location: He's out there! somewhere!!!!

Re: Unable to load Java Class

Postby ileola » Fri Jul 29, 2011 5:56 am

eventually raised this as an issue with SAP - apparently they skipped a version of a component MESSAGING

They will be releasing the missing SCA - will let you know if it resolves the issue
ileola
 
Posts: 39
Joined: Tue Aug 12, 2003 4:51 am


Return to SAP Process Integration (SAP PI/XI)

Who is online

Users browsing this forum: No registered users and 1 guest





loading...


This website is not affiliated with, sponsored by, or approved by SAP AG.