This website is not affiliated with, sponsored by, or approved by SAP AG.

Unable to add catalog items to shopping cart

All postings related to SRM only

Moderators: Snowy, thx4allthefish

Unable to add catalog items to shopping cart

Postby Anand » Tue Oct 07, 2008 8:48 am

SRM gurus,
I have an issue where I am unable to add a catalog item to a shopping cart.
We have SRM 4.0 (SRM_SERVER 500) and we have this issue only after the support packs have been impelemented. The support pack levels are given below.
FYI.. the CCM is not upgarded only the other SRM related stuff has been patched.

SAP_ABA 640 0021 SAPKA64021
SAP_BASIS 640 0021 SAPKB64021
CCM 200_640 0009 SAPK-26409INCCM
SRM_SERVER 500 0013 SAPKIBKS13

I have run the program /CCM/INITIALIZE_CME after the support pack and also compared the UOM settings. I could not find the reason for this issue.

I would appreciate your advise on this.

Thanks and Regards,
Anand
Anand
 
Posts: 83
Joined: Fri Jan 10, 2003 6:52 am

Re: Unable to add catalog items to shopping cart

Postby dehinson » Wed Oct 08, 2008 1:17 pm

What errors are you getting? Do you check the log in SLG1? Did you debug BBP_CATALOG_TRANSFER?

Also, is this a hosted catalog outside of your firewall? If so, it could be a security settings.

Regards, Dean.
dehinson
 
Posts: 143
Joined: Mon Oct 21, 2002 10:39 am
Location: Charleston, SC

Re: Unable to add catalog items to shopping cart

Postby Anand » Wed Oct 08, 2008 5:32 pm

Thanks Dean,

I am getting an error message ‘Enter at least one item or one limit’ after the catalogue item is added to the shopping cart. The shopping cart is empty.
I could not find any useful messages in SLG1. I need to check with BASIS if the catalog is outside of the firewall.

Regards, anand
Anand
 
Posts: 83
Joined: Fri Jan 10, 2003 6:52 am

Re: Unable to add catalog items to shopping cart

Postby SRMnewbie » Mon Oct 13, 2008 11:31 am

If you have no luck deugging the BADI, try catching the source code behind the website to see if the catalogue is creating the right OCI data and sending back to the correct address, it sounds liek it is send back to teh right address but contains a possible strange instantance of a OCI field.

Hope that helps.
SRMnewbie
 
Posts: 120
Joined: Thu Oct 11, 2007 9:30 am


Return to SRM Supplier Relationship Management

Who is online

Users browsing this forum: No registered users and 2 guests





This website is not affiliated with, sponsored by, or approved by SAP AG.