This website is not affiliated with, sponsored by, or approved by SAP AG.

Screen output without connection to user.

Interfaces (ALE, IDOC, RFC, EDI etc.)

Moderators: Snowy, thx4allthefish

Screen output without connection to user.

Postby Swalt » Thu Sep 25, 2003 4:16 am

Hi all,

I've got the following error in the transactional RFC Log (SM58):
"Screen output without connection to user."

I understand what the error message means but in my context it makes no sense.

I have created a custom outbound IDoc which is very simple: 1 segment in the IDoc. And the IDoc is being transmitted between two SAP systems (from Enterprise to 4.6C) I have created a program that creates these IDocs and it all works fine. When I commit the IDoc to the port, the IDoc even goes to success status 30: IDoc sent to R/3 System or external program.

The RFC has worked for other message types so I know that's not the issue.

But the tRFC gets stuck with this error message. What gives? If anyone has any ideas, please let me know.

Thanks
Swalt
Swalt
 
Posts: 65
Joined: Tue Nov 19, 2002 11:56 am
Location: Jo'burg, South Africa

Postby ssii » Thu Sep 25, 2003 4:21 am

Hi,

Did you test the reception of your IDOC with WE19 ???

If yes, are you sure that the user used to connect to the reception system have the permission to do the job ???

SSII
ssii
 

Postby Swalt » Thu Sep 25, 2003 10:20 am

SSII,

I don't know why I didn't check this first, but it was an error related to the user BASIS had put on the RFC connection but with my user it worked. The user has to be a dialogue user (!) and authority also had to be sorted out.

Thanks,
Swalt
Swalt
 
Posts: 65
Joined: Tue Nov 19, 2002 11:56 am
Location: Jo'burg, South Africa


Return to Interfaces

Who is online

Users browsing this forum: No registered users and 4 guests





This website is not affiliated with, sponsored by, or approved by SAP AG.