Page 1 of 1

Problems starting WF in internal table loops

PostPosted: Fri Nov 29, 2002 12:57 pm
by conquer
I have a program that collect severals Purchase Orders numbers into a internal table and launch, in a "loop at table" command, the event BUS2012.ReleaseStepCreate for each order in this loop.
The function module SWE_EVENT_CREATE is used to start de WF.
The problem is that sometimes the Workflow is not started for some items in the internal table.
Example: for a set of 10 purchase order numbers, only 3 is launched, the others not. In another time, all 20 items, in a set of 20, is launched correctly. In another moment, only 7 is launched, in a set of 8, and so on.

The logic is following:

Loop at table01.

zobject = 'BUS2012'.
zobjkey = table01-ebeln.
zevent = 'releaseStepCreated'.
CLEAR zapplicant.
zapplicant-otype = 'US'.
zapplicant-objid = sy-uname.

CALL FUNCTION 'SWE_EVENT_CREATE'
EXPORTING
objtype = zobject
objkey = zobjkey
event = zevent
creator = zapplicant
* TAKE_WORKITEM_REQUESTER = ' '
* start_with_delay = ' '
start_recfb_synchron = 'X'
NO_COMMIT_FOR_QUEUE = ' '
* DEBUG_FLAG = ' '
* NO_LOGGING = ' '
* IDENT =
IMPORTING
event_id = zeventid
* TABLES
* EVENT_CONTAINER = ZCONTAINER
EXCEPTIONS
objtype_not_found = 01.
* OTHERS = 2

COMMIT WORK.
ZRESULT = sy-subrc.

Endloop.


Does anyone knows what can be happening ?

Thanks

PostPosted: Thu Dec 05, 2002 12:21 pm
by JayaKumarPM
Hi,,

If the workflow is not getting triggered for all items ,, you may have to check whether theres is any Check function module or receiver function module attached to the Event which is fired.

Bye,
Jayakumar

Re: Problems starting WF in internal table loops

PostPosted: Wed May 16, 2012 9:56 am
by shrestharaju
Hi Conquer,

This is a decade old question. You must have already resolved the issue. Can you please let me know how you resolved it.

I have the same issue now (for BUS2032).

Thanking you.
Raju

Re: Problems starting WF in internal table loops

PostPosted: Wed May 16, 2012 10:03 am
by Gothmog
It is 10 years old - Conquer hasn't visited this site since 2003.
Please do not raise an old topic from its grave, start a new one for your specific problem.
Locked.