This website is not affiliated with, sponsored by, or approved by SAP AG.

CUA - Problems deleting users

SAP Security

Moderators: Snowy, thx4allthefish, jurjen

CUA - Problems deleting users

Postby henrik » Tue Jan 31, 2012 11:00 pm

Hi,
I have a strange problem... In our CUA environment things usually work just fine, but recently we started seeing a problem when deleting users.
"Role assignment to user xxx deleted" would show up in the SCUL log in white - so basically just as it hasn't been processed. The user has had the system removed from the CUA master, but the account is still present in the child system - although with no roles or profiles.

Has anyone seen this before, and more importantly, does anyone have any idea on how to resolve the issue?

thanks
Henrik
www.turnkeyconsulting.com.au
henrik
 
Posts: 493
Joined: Wed Oct 23, 2002 6:38 am
Location: London, UK

Re: CUA - Problems deleting users

Postby thx4allthefish » Thu Feb 02, 2012 8:36 am

Can you please provide some more information? Your CUA master is a ... release xxx ... and the children attached (=the erreanous child)? Same release?
curiousorange wrote:I give up. Humanity isn't worth saving. Why is there never a Vogon Constructor Fleet around when you really need one?
thx4allthefish
 
Posts: 5694
Joined: Sat Oct 26, 2002 6:18 pm
Location: barolo barrel

Re: CUA - Problems deleting users

Postby henrik » Sun Feb 05, 2012 6:48 pm

Sorry about the delay in responding.

Master is Solution manager, version 7.01
Child is ECC 7.02

/henrik
www.turnkeyconsulting.com.au
henrik
 
Posts: 493
Joined: Wed Oct 23, 2002 6:38 am
Location: London, UK

Re: CUA - Problems deleting users

Postby Grimster » Wed Feb 08, 2012 6:14 am

I've seen this when there's been a problem gaining confirmation from the target system, it usually transpires that there's something amiss with the RFC connections.
Just make sure your RFC from the target client back to CUA is still working and the username running the RFC isn't locked in the CUA client and the RFC passwords are correct, that usually fixes it for us.
Grimster
 
Posts: 17
Joined: Fri Feb 20, 2004 5:41 am

Re: CUA - Problems deleting users

Postby os » Thu Feb 09, 2012 3:00 am

There were problems until recently with locks.

When performing role assignments / removals the system placed a lock on both the role and the user master record. This is now only the role as it is not a change to the user master record itself.

This created a few knock-on affects for BAPIs and the CUA. I would check OSS notes for your SPs levels on the systems. Starting point is 1416149.

Good luck and keep us in the loop when it works again.
os
 
Posts: 469
Joined: Wed Dec 21, 2005 10:51 am

Re: CUA - Problems deleting users

Postby henrik » Thu Feb 09, 2012 10:25 pm

Hi os,
That's a good find! Looks like that might be related. Passed it on to the basis guys to see if we can get that implemented.
thanks for that

/h
www.turnkeyconsulting.com.au
henrik
 
Posts: 493
Joined: Wed Oct 23, 2002 6:38 am
Location: London, UK


Return to SAP Security

Who is online

Users browsing this forum: No registered users and 3 guests





loading...


This website is not affiliated with, sponsored by, or approved by SAP AG.