SAP Upgrade 4.7 --> ECC 5.0 (security roles broken)

SAP Security

Moderators: Snowy, thx4allthefish, jurjen

Post Reply
asad80
Posts: 5
Joined: Mon Jun 06, 2005 4:22 pm
Location: Chicago, IL, USA
Contact:

SAP Upgrade 4.7 --> ECC 5.0 (security roles broken)

Post by asad80 » Thu Aug 19, 2010 8:09 am

Hi guys,

I wanted to ask what can break in Security roles if an upgrade takes place from SAP 4.7 to ECC 5.0 in Security roles in SAP ?

If roles can break because of missing authorizations what could be an easy answer to that ?

berryd
Posts: 179
Joined: Fri Feb 27, 2004 6:30 am
Location: here.. I think

Re: SAP Upgrade 4.7 --> ECC 5.0 (security roles broken)

Post by berryd » Thu Aug 19, 2010 2:04 pm

Hi

Do you have some examples of 'roles that have broken' for you in your upgrade or is this a hypothetical exercise?
Real Daleks don't use the stairs. They just level the building.
Well - okay - so now they can fly - that's not fair!

John A. Jarboe
Posts: 322
Joined: Tue Mar 07, 2006 8:48 am

Re: SAP Upgrade 4.7 --> ECC 5.0 (security roles broken)

Post by John A. Jarboe » Sat Aug 21, 2010 12:02 pm

It is very likely that the security roles "will be broken" when you upgrade. In Each upgrade SAP add Authorization checks into transaction codes and in some cases removes the chec. By doing so your roles are not guaranteed to work, in other words break.
You can use transaction code SU25 and SU26 to determine what neesed to be addresses.
John A. Jarboe

Post Reply