This website is not affiliated with, sponsored by, or approved by SAP AG.

Price and Cost delta not working from R/3 to BW

Business Warehouse

Moderators: Snowy, thx4allthefish

Price and Cost delta not working from R/3 to BW

Postby vishwa1978 » Sun May 09, 2010 9:59 pm

Hi Experts,

We are facing a typical issue, for which we are unable to solve the solution. Here is the issue

The data is getting loaded from VAITM and SSL into BW system 7.0. The VAITM extractor was enhanced with few COST and pricing (using Z-fields) fields and the data is getting loaded into DSO1. Similarly SSL extractor having the scheduled line items is getting loaded into BW system DSO2.

Then the data from both these DSO goes to DSO3 with some look ups and calculations. From that DSO3 the data is loaded into the CUBE.
Now the issue is “if the cost is changed without the change in the schedule line data, no delta is triggered and the cube is not updated" .
In other words the "COST/Price changes in VAITM/DSO1 without an accompanying schedule line change are not triggering a delta that updates the Open Order and Booked Values through SSL/DSO2".

How to solve this issue and get my Delta working in this case.

Thanks and Regards

Vishwanath
vishwa1978
 
Posts: 1
Joined: Sun May 09, 2010 9:49 pm

Re: Price and Cost delta not working from R/3 to BW

Postby El Belgio » Fri May 21, 2010 3:49 am

Where do you fill the enhanced fields? If you don't fill them in an SD user exit, but in the "default" user exit for BW, then it's quite obvious that no delta's are triggered as the delta mechanism is built in the SD application. So you must actually trigger a delta within the application itself.
El Belgio
 
Posts: 2576
Joined: Tue Oct 22, 2002 7:15 am
Location: back in rainland


Return to Business Warehouse

Who is online

Users browsing this forum: No registered users and 5 guests





loading...


This website is not affiliated with, sponsored by, or approved by SAP AG.