This website is not affiliated with, sponsored by, or approved by SAP AG.

no spool generated with ME9F

Development SAPscript/ Smartforms

Moderators: Snowy, thx4allthefish, YuriT, Gothmog

no spool generated with ME9F

Postby ike66 » Wed May 07, 2014 9:21 am

Hi experts,

I created a print program, setted in NACE tcode, which prints Purchase Orders, convert them in pdf and send by email to the vendors.
MM users call tcode ME9F and insert several P.O. in select options.
All works correctly but - sometimes - for a certain P.O., no spool is generated, so the programs picks up the previous spool (wrongly) for pdf conversion.
In this way, sometimes, some vendor receives his email with the attached pdf (with correct file name <order nr><vendor name>.pdf) that contains someone else's order. We have no dump and no exception during PO processing.

This is a very hard problem for MM users that ask me a quick solution.
For an internal policy, I can't use debug in Production Environment and in Test this never happens.

Do you have any idea of possible causes of this no-spool creation?

Thanks in advance,
Sandro
ike66
 
Posts: 5
Joined: Wed Nov 28, 2012 10:17 am

Re: no spool generated with ME9F

Postby Gothmog » Wed May 07, 2014 9:31 am

I'd say the problem is in the part where you
convert them in pdf and send by email to the vendors

How are you doing this?
68 74 74 70 3a 2f 2f 74 69 6e 79 75 72 6c 2e 63 6f 6d 2f 62 64 6f 37 6d 77 67
Gothmog
 
Posts: 1941
Joined: Wed Sep 12, 2007 4:46 am
Location: Probably not home

Re: no spool generated with ME9F

Postby ike66 » Wed May 07, 2014 10:42 am

Thanks for your reply.

I suppose there's no matter in conversion since this procedure has been working for several years.
Recently, I don't know what is changed, sometimes (and only sometimes) the P.O. is not printed. No spool generated.
so, if you call ME9F for this P.O. only, the email is sent with a corrupt pdf attachment (only 1kB)...
If you try to open that using SOST, it returns a system error.
if you call ME9F and insert this P.O. in the select option among other P.O.'s, the relative email contains an apparently correct pdf attachment (100 kB or more) but when you open it you see that it contains the same P.O. sent with previous email.
For this reason I don't think is a conversion matter.

Thanks, anyway.
Sandro
ike66
 
Posts: 5
Joined: Wed Nov 28, 2012 10:17 am

Re: no spool generated with ME9F

Postby Gothmog » Mon May 12, 2014 3:40 am

The conversion, maybe not, but the way you send the converted data, most certainly.
68 74 74 70 3a 2f 2f 74 69 6e 79 75 72 6c 2e 63 6f 6d 2f 62 64 6f 37 6d 77 67
Gothmog
 
Posts: 1941
Joined: Wed Sep 12, 2007 4:46 am
Location: Probably not home


Return to SAPscript/Smartforms

Who is online

Users browsing this forum: No registered users and 5 guests





loading...


This website is not affiliated with, sponsored by, or approved by SAP AG.