This website is not affiliated with, sponsored by, or approved by SAP AG.

Table / Template cell turns black !!!

Development SAPscript/ Smartforms

Moderators: Snowy, thx4allthefish, YuriT, Gothmog

Table / Template cell turns black !!!

Postby new2sapfans » Mon May 04, 2009 12:55 pm

Hi,

In my smartform, I design a template or table using a table painter.
This creates the table but as the measurements in the background can be in decimal places;
I hit the "Table details" button on the Table tab,
and fine-tune the column widths by manually adjusting (or rounding) the widths in the detailed section.

What happens sometimes is that "some" cells of such "manually adjusted" line types turn out completely BLACK.
(only in the printout, not in the print preview)

The only way I can get around this issue is to re-create another similar line type (using the table painter)
and not making any manual adjustments to it. Use the new line type in my table, and delete the old line type.

This gets tiring, especially if the line type has many cells, and a very fine control is required for exact positioning of data.

Has anyone come across such behaviour? and tried to resolve it?
Any ideas regarding its root cause? and why only "some" cells behave in such a way?

Any help would be highly appreciated.
new2sapfans
 
Posts: 71
Joined: Thu Jan 01, 2009 11:01 am

Re: Table / Template cell turns black !!!

Postby misha » Sun Jul 26, 2009 6:34 am

You might have put some value in the box shading by mistake.Removing it will blank the shade
misha
 
Posts: 5
Joined: Sat May 30, 2009 12:48 am

Re: Table / Template cell turns black !!!

Postby Rozella » Wed Feb 02, 2011 9:13 am

Hi,
we are currently facing similar issue. What was the solution around this?
Thanks a lot for the help.
Rozella
 
Posts: 1
Joined: Wed Feb 02, 2011 9:10 am

Re: Table / Template cell turns black !!!

Postby eralper » Fri Feb 04, 2011 1:46 am

Hi,
I have the same problem with one difference.

I see the table cell background in white color.
But when I print the document using my local printer on development system it returns to black!
But in production environment the same printer prints correct :)

I guess there is some thing wrong with printer definition.
But it is strange that this happens only on one certain cell.
Eralper
http://www.kodyaz.com
eralper
 
Posts: 1
Joined: Thu Feb 03, 2011 3:02 am

Re: Table / Template cell turns black !!!

Postby javvvi » Mon Aug 22, 2011 5:55 am

It's good to met people with the same problem!! I was felling alone.

I have a table and the width columns have decimals, it functions ok for a while but after an hour or maybe the next day the width of colums change to enter values.

Nobody knows why? I will try the half solution of the first comment, creating again an equal line and deleting the origina one.
javvvi
 
Posts: 1
Joined: Mon Aug 22, 2011 5:48 am

Re: Table / Template cell turns black !!!

Postby Gothmog » Mon Aug 22, 2011 6:01 am

javvvi wrote:It's good to met people with the same problem!! I was felling alone.

I don't know where you met these people, since your problem has nothing to do with this thread...
Anyway, do not highjack old threads, start a new one for your problem.

Locked.
68 74 74 70 3a 2f 2f 74 69 6e 79 75 72 6c 2e 63 6f 6d 2f 62 64 6f 37 6d 77 67
Gothmog
 
Posts: 1941
Joined: Wed Sep 12, 2007 4:46 am
Location: Probably not home


Return to SAPscript/Smartforms

Who is online

Users browsing this forum: Google [Bot] and 4 guests





loading...


This website is not affiliated with, sponsored by, or approved by SAP AG.