prints two char format in the one table(smartforms)

Development SAPscript/ Smartforms

Moderators: Snowy, thx4allthefish, YuriT, Gothmog

Post Reply
kkktank
Posts: 13
Joined: Mon May 26, 2008 8:29 am

prints two char format in the one table(smartforms)

Post by kkktank » Fri Oct 24, 2008 1:44 am

smartforms, main window, table.
in the body of this table, I wanna print two types of lines. Depending on the content of the line data,
it will print out normal or bold char format. But frustratingly, I failed and found the output is all Bold.

Is it a bug in smartforms or there is something I should be care about?

BradB
Posts: 685
Joined: Wed Mar 22, 2006 10:27 am
Location: Standing right behind you

Re: prints two char format in the one table(smartforms)

Post by BradB » Fri Oct 24, 2008 8:15 am

There's no bug. Your text elements specify the line type and carry the paragraph format, so if you want to alternate formats, you need to add additional text elements and conditions to trigger them for each loop pass.
Ironman Triathlete and SAP Dev/Config Expert
(which is harder?)

kkktank
Posts: 13
Joined: Mon May 26, 2008 8:29 am

Re: prints two char format in the one table(smartforms)

Post by kkktank » Sun Oct 26, 2008 9:20 am

thanks Brad. But the problem may be caused by another werid setting of smartforms.

I created two rows in the BODY of the table. the two rows are very likely to each other, excpet I wanna display different formats for these two rows. So after I created one row, I copy it and paste as to created the second row. :evil: It seems there is some problem in Smartforms' element copy and paste operation.
After I deleted all the rows and re-create the two rows, the char format can display properly.

Post Reply