This website is not affiliated with, sponsored by, or approved by SAP AG.

ALV Grid: displaying negative amounts

Development (ABAP Development WorkBench, ABAP/4 programming)

Moderators: Snowy, thx4allthefish, Gothmog, YuriT

ALV Grid: displaying negative amounts

Postby MickeyJ on Sun Aug 24, 2003 9:07 pm

Hi there, I am working with the ALV Grid control and am displaying currency amount fields. I am finding that when a negative amount is displayed it shows as ' 125.12 -', rather than ' -125.12'.
I have defined my cfieldname which seems to be working fine. I am wondering whether anyone has any ideas on how to correct this, or is this just how ALV Grid displays negatives.

Thanks in advance.

MJ

MickeyJ
 

Postby aussie fatboy on Sun Aug 24, 2003 9:31 pm

If you want to display the number as a SAP numeric, this is how SAP outputs it.

If you launch Excel from the ALV display, ALV will (should) convert it to display the negative at the start of the field.

If you need to run this in background and download the data to excel via other means, you might need to consider outputting the amount field as a char and moving the sign yourself (FM CLOI_PUT_SIGN_IN_FRONT).
aussie fatboy
 
Posts: 827
Joined: Sun Oct 20, 2002 11:34 pm
Location: Melbourne, Australia

Postby MickeyJ on Sun Aug 24, 2003 10:56 pm

Thanks Aussie FB. Will probably leave as is unless the user complains about it.

Cheers
MickeyJ
 


Return to ABAP

Who is online

Users browsing this forum: Google [Bot] and 12 guests



This website is not affiliated with, sponsored by, or approved by SAP AG.