This website is not affiliated with, sponsored by, or approved by SAP AG.

Issue in BTE for FI-Document Post

Development (ABAP Development WorkBench, ABAP/4 programming)

Moderators: Snowy, thx4allthefish, YuriT, Gothmog

Issue in BTE for FI-Document Post

Postby vanchasri » Thu Apr 23, 2015 3:01 pm

Hi Experts,

iam trying to populate the value from filed BSEG-SGTXT to BSEG-KONTL before posting , i tried to implement BTE's (0120, 0130, 0140) , after changing the entry in BSEG , the valued always restoring from the original values. .
my code in BTE as below:
Z_XXXX_INTERFACE_00001140

data: lv-index type sy-index.

If T_BSEG[] is not initial.
loop at t_bseg into wa_bseg.
lv-index = sy-tabix.
if wa_bseg-sgtxt ne ' '.
wa_bseg-kontl = wa_bseg-sgtxt.
clear wa_bseg-sgtxt.
modify t_bseg from wa_bseg index lv-index TRANSPORTING sgtxt kontl.

endif.
endloop.
endif.

endfrom.

once the control come out of the FM , the values of BSEG are getting restores, please let me know how can fix the issue?

Thanks
NK
vanchasri
 
Posts: 4
Joined: Thu Apr 23, 2015 1:30 pm

Re: Issue in BTE for FI-Document Post

Postby EricR » Thu May 07, 2015 3:21 pm

You can't do this in a publish & subscribe BTE - those are for updating 3rd party / self-developed applications only (i.e., they can't update the posting - they can only forward it to something else).

Why not do this with a simple substitution in FI?
EricR
 
Posts: 142
Joined: Sat Apr 28, 2007 10:35 am


Return to ABAP

Who is online

Users browsing this forum: Google [Bot] and 6 guests





loading...


This website is not affiliated with, sponsored by, or approved by SAP AG.