This website is not affiliated with, sponsored by, or approved by SAP AG.

BAPI BAPI_GOODSMVT_CREATE Issue

Development (ABAP Development WorkBench, ABAP/4 programming)

Moderators: Snowy, thx4allthefish, YuriT, Gothmog

BAPI BAPI_GOODSMVT_CREATE Issue

Postby Abdul » Tue Aug 12, 2014 12:04 pm

We are planning to use SAP A&D solution for subcontracting PO ( Refurbishment with changed material number SERRU = 2) and with serialized materials. All the configurations are well done in our sandbox and the testing with standard SAP transaction is successful
Scenario is :
1. All swiches were activated to use this solution as per SAP recommandation
2. All configs are done in ECC6
3. Mater data in BOM is set as recommended by SAP
4. Create subcontracting PO using a BOM (to send material M1 to supplier and then receive M2)
5. M1 have a serial number S1 (and equipment record)
6. We create an outbound delivery using ADSUBCON (Serial number S1)
7. In VL02N we pick and post GI
8. In MIGO we receive M2 (Mvt 101) and we consume M1 (Mvt 543)
9. The equipment record is deleted (M1, S1) and new equipement record is created (M2, S1) with same serial number and the history from initial equipment is transfered to the new equipment.
10. It is working well when using standard way (ADSUBCON, VL02N, MIGO)
Problem :
For a business reason we want to use all these 3 transactions (ADSUBCON, VL02N, MIGO) in one z-transaction called ZPO. In ZPO for the GR we are using the BAPI_GOODSMVT_CREATE and here we are facing a problem. All previous steps are well executed except the step 9. We are getting 2 equipments records instead of only one.
The previous equipment is still there. A new equipment is created without transfer of history
BAPI BAPI_GOODSMVT_CREATE is not transfering history and is not deleting previous equipment.
please help.
Abdul
Abdul
 
Posts: 58
Joined: Thu Feb 06, 2003 3:08 pm
Location: Montreal, Canada

Re: BAPI BAPI_GOODSMVT_CREATE Issue

Postby q4u » Wed Aug 13, 2014 5:39 am

Hi,
Assuming the BAPI has that functionality in the first place, maybe it's a timing issue? Is SAP still running updates in the background from the previous transactions?
q4u
 
Posts: 439
Joined: Wed Mar 08, 2006 7:02 am

Re: BAPI BAPI_GOODSMVT_CREATE Issue

Postby Abdul » Wed Aug 13, 2014 2:04 pm

Thanks for your reply q4u
No I don't think its a timing issue. we tried it in many way with abaper and with debug step by step and it really seems this bapi have never worked in the way we are using it.
No we have to find an alternative solution.
Abdul
 
Posts: 58
Joined: Thu Feb 06, 2003 3:08 pm
Location: Montreal, Canada


Return to ABAP

Who is online

Users browsing this forum: No registered users and 9 guests





loading...


This website is not affiliated with, sponsored by, or approved by SAP AG.