This website is not affiliated with, sponsored by, or approved by SAP AG.

Performance problem on KEKO Read

Development (ABAP Development WorkBench, ABAP/4 programming)

Moderators: Snowy, thx4allthefish, YuriT, Gothmog

Performance problem on KEKO Read

Postby aenimae » Thu Jun 05, 2014 3:39 am

Hi experts,

This is my first post here, hope it will not be a stupid question :)
Sorry for my imprecise english btw :)
My scenario is:

In outbound delivery monitor (tcode VL06O) during posting of a very large outbound delivery goods issue (about 70 items), the execution time is really long, and this is giving problem in user's operation.
As for my analysis, the problem is located on the processing of FM 'CK_F_KEKO_KEPH_READING', precisely on the SQL statement of KEKO table read, that is executed in sequential pattern, even if the statement contains key fields as selection parameters.

Runtime is about 7 sec. per item, for a total of about 8 min.
I've refreshed statistics on table KEKO and the runtime was reduced of about 30 sec., but it's still too long for an operation that usually requires a small time to execute (translation: really hard to explain it to users).

I've also looked for SAP Notes about the issue, but nothing was found.
Next step will be the creation of a custom index on table for the only EQ clause in select (KALNR)?
Have someone faced same or similar issue?
We're on an EHP6 environment.

Thank you in advance,

Nino
aenimae
 
Posts: 2
Joined: Thu Jun 05, 2014 2:52 am

Re: Performance problem on KEKO Read

Postby Gothmog » Thu Jun 05, 2014 4:00 am

What do you get when you use ST05 and Explain the SQL statement?
68 74 74 70 3a 2f 2f 74 69 6e 79 75 72 6c 2e 63 6f 6d 2f 62 64 6f 37 6d 77 67
Gothmog
 
Posts: 1941
Joined: Wed Sep 12, 2007 4:46 am
Location: Probably not home

Re: Performance problem on KEKO Read

Postby aenimae » Thu Jun 05, 2014 4:52 am

Gothmog wrote:What do you get when you use ST05 and Explain the SQL statement?


It takes me to an empty internet page. Maybe I'm doing something wrong?
aenimae
 
Posts: 2
Joined: Thu Jun 05, 2014 2:52 am

Re: Performance problem on KEKO Read

Postby Gothmog » Thu Jun 05, 2014 6:34 am

Most probably - never seen that happen. :|
68 74 74 70 3a 2f 2f 74 69 6e 79 75 72 6c 2e 63 6f 6d 2f 62 64 6f 37 6d 77 67
Gothmog
 
Posts: 1941
Joined: Wed Sep 12, 2007 4:46 am
Location: Probably not home


Return to ABAP

Who is online

Users browsing this forum: Google [Bot] and 8 guests





loading...


This website is not affiliated with, sponsored by, or approved by SAP AG.