This website is not affiliated with, sponsored by, or approved by SAP AG.

Help: Locating Z message from MIGO posting error log.

Development (ABAP Development WorkBench, ABAP/4 programming)

Moderators: Snowy, thx4allthefish, YuriT, Gothmog

Help: Locating Z message from MIGO posting error log.

Postby tsumek » Fri May 09, 2014 4:23 am

Greetings,

So the User got a Z message error in his log after trying to post a Material Document in MIGO. It said that he had to enter a trading partner for an intercompany account. Now, he checked everything he could and claims that everything is in order, so he asked me to find out where and why the message triggered.

Now, the situation stands like this.

I am not allowed to run MIGO in order to debug it. A where-used for the specific message in SE91 yielded nothing. I checked MBCF0002 and MBCF0005, and MB_MIGO_BADI and found no specific mention of the message class. I located the Includes connected to posting in MIGO but I have been unable to find anything yet.

Is there any way I could find out where the Z message is? I'm just two months into ABAP so I may be missing something really obvious here.

-tsumek
tsumek
 
Posts: 12
Joined: Fri May 09, 2014 4:05 am

Re: Help: Locating Z message from MIGO posting error log.

Postby knowledgeWorx » Mon May 12, 2014 6:48 am

Most probably, it's coming from an error table that is returned from a user exit and has a return structure like the commonly-used BAPIRET2, where you just return a table line that contains a message class and number. The system will then display the according message dynamically. Of course, that means that a where-used for this message will fail, since it's not used directly in a MESSAGE statement.
I don't have a better idea than to check any user exits that exist for MIGO; this SCN topic has a list of them: http://scn.sap.com/thread/138960.
Of course, if you had debugging rights you could do a break point at the statement MESSAGE and see if it finds any dynamic messaging, then proceed from there. That's probably the fastest way, if you can get the authorization somehow.
SAP Enthusiast, PM/PS/CS Consultant, Hobby Blogger.
http://www.dev-workbench.com
knowledgeWorx
 
Posts: 17
Joined: Mon May 05, 2014 9:36 am
Location: Germany

Re: Help: Locating Z message from MIGO posting error log.

Postby Grogan » Mon May 12, 2014 4:28 pm

Yep, sounds like you have done all the right steps. As knowledgeWorx says you can keep poking around in user exits and hope to find it, but I would be included to just tell them you can't do anything further without authorisation to run and debug.
Grogan

Award cash if useful.
Grogan
 
Posts: 365
Joined: Thu Aug 04, 2005 7:16 pm
Location: Australia

Re: Help: Locating Z message from MIGO posting error log.

Postby tsumek » Tue May 13, 2014 12:38 am

Thanks! I checked the User Exits once again. Zilch. I had a test case made in Quality, but the error didn't come up there. Meanwhile, the User claims that he continues to face it on Production.

So I have asked for authorization to run and debug MIGO. Setting a breakpoint on MESSAGE does seem like the only way to resolve this right now. Should I also ask to do this for that particular User's login?

-tsumek
tsumek
 
Posts: 12
Joined: Fri May 09, 2014 4:05 am

Re: Help: Locating Z message from MIGO posting error log.

Postby Sharpshooter » Tue May 13, 2014 6:45 am

Running an ABAP trace may also be helpful.
Good luck!
Sharpshooter
 
Posts: 1171
Joined: Wed Mar 17, 2010 12:01 pm
Location: In the dark

Re: Help: Locating Z message from MIGO posting error log.

Postby tsumek » Tue May 13, 2014 7:43 am

Sharpshooter wrote:Running an ABAP trace may also be helpful.


I dream of the day I get that authorization. I would treasure it as I would a firstborn child.
tsumek
 
Posts: 12
Joined: Fri May 09, 2014 4:05 am


Return to ABAP

Who is online

Users browsing this forum: Yahoo [Bot] and 7 guests





This website is not affiliated with, sponsored by, or approved by SAP AG.