This website is not affiliated with, sponsored by, or approved by SAP AG.

Error: NiHLGetNodeAddr

Basis (Basis Technology Modules: Basis Component/System Administration, GUIs)

Moderators: Snowy, thx4allthefish

Error: NiHLGetNodeAddr

Postby trunolimit » Sat Jun 07, 2014 7:37 pm

Hello SAP FANS,

I'm new here.

In our plant we are running SAP GUI 730. For some reason SAP works fine if creat the login as a custom app server but when I switch to group/server selection I get Error: NiHLGetNodeAddr.

what does that mean?
trunolimit
 
Posts: 4
Joined: Sat Jun 07, 2014 6:40 pm

Re: Error: NiHLGetNodeAddr

Postby Zavaros » Tue Jun 10, 2014 4:48 am

hello,

can you please put here the whole message?

as I understand you get the message in GUI. Have you checked the message server trace file?

Regards,
Zav.
Zavaros
 
Posts: 756
Joined: Thu Oct 24, 2002 10:50 pm
Location: Hungary

Re: Error: NiHLGetNodeAddr

Postby trunolimit » Thu Jun 12, 2014 2:26 pm

What is a message server trace file?

here is what happens. I try to add a new entry

Image

I then fill out the info and I get a ?

Image

I'm extremely limited when it comes to SAP. I will do a search for message server trace file. From googling around I read that if you update from version 6 to 7, certain login files are in one place but if you do a clean install of SAP 7.3 the login files are in a different place. So I tried taking all the login files I could find from a machine that is working and place them in several places on this machine that has a problem. The only progress i made doing that is that the NiHLGetNodeAddr error doesn't come up instead it goes straight to the ? error.

I really appreciate the help. Thank you.
trunolimit
 
Posts: 4
Joined: Sat Jun 07, 2014 6:40 pm

Re: Error: NiHLGetNodeAddr

Postby trunolimit » Thu Jun 12, 2014 2:53 pm

So I found some SAPlogin.ini files from a working computer and copied them over to the non working machine.

The .old files are the original files. I notice that the working computer had 1 more file than the non working PC
Image

So the FRP login popped up on the GUI screen but when I click on it I get this error
Image

when I click yes I get this message
Image
Last edited by trunolimit on Thu Jun 12, 2014 3:54 pm, edited 1 time in total.
trunolimit
 
Posts: 4
Joined: Sat Jun 07, 2014 6:40 pm

Re: Error: NiHLGetNodeAddr

Postby trunolimit » Thu Jun 12, 2014 3:54 pm

And I seem to have solved it.

doing what I did above by placing those saplogin files in the common directory I was presented with a new problem and in order to fix that problem I just had to add

sapmsPRD 3600/tcp
sapmsFRP 3620/tcp

to the services file in C:\Windows\System32\drivers\etc. After I did that all worked very well.
trunolimit
 
Posts: 4
Joined: Sat Jun 07, 2014 6:40 pm


Return to Basis

Who is online

Users browsing this forum: No registered users and 4 guests





loading...


This website is not affiliated with, sponsored by, or approved by SAP AG.