This website is not affiliated with, sponsored by, or approved by SAP AG.

Configuring HTTP node to send SMS

Basis (Basis Technology Modules: Basis Component/System Administration, GUIs)

Moderators: Snowy, thx4allthefish

Configuring HTTP node to send SMS

Postby kt0007 » Tue Mar 12, 2013 10:23 am

Hello fellow SAP fans,

I came over a problem with setting HTTP node in SCOT for sending SMS. Kidly post options/ideas/suggestions.

Short overview: There are two ways to go if you want to send an SMS to a mobile number:

    Using SMTP node: SMS is packed as e-mail, sent to a third party gateway and the gateway process it as SMS.
    Pretty common way to do it even outside SAP.
    Our gateway does not support this way.
    Using HTTP node: SMS is sent via HTTP node using/calling URL like:
    http://mygate.com/sms.php?
    login=mylogin&
    password=mypswd&
    action=send_sms&
    number=<reci_addr>&
    message=<message>

    We have to use the HTTP node way.

I found a very nice guide to set up the node, virtual host and such at http://punarvasi.com/configuring-sms-in-a-sap-system, but sadly, I was not able to send the sms.

Now what I did besides setting stuff in SCOT, SICF, SPRO, SA14 as told:

1. Ask for forewall ports to get opened
I asked the third-party gateway's provider about the port his app is listening on and then asked our server hosting to open these ports. They say they did but also that my send request didn't even reached the firewall.

2. Routing test in TC SCOT
When I test the node and provide address type PAG and number in format "SMS:countrycodephonenumber", eg. SMS:00420777123456 I get all green = no errors in any step.

3. TC SOST check and reprocess
After sending the SMS from TC SBWP as told in the guide, I checked TC SOST. The send request is here with message SO672 - Wait for communication service. If I process it manually (Start Send Process For Selection button) I get XS751 - Message cannot currently be transferred to node SMS:00420777123456 due to connection error.

4. TC SMICM check
When looking to the ICM monitor I get:
[Thr No.xx] *** WARNING => Connection request from (xx/yyyy/z) to host: gatewayIP, service: 8080 failed (NIECONN_REFUSED).

Question
How can I force port to the address? In SMICM I keep seeing 8080 which I assume to be port but I want to try port 80.

Thank you for your time.
kt0007
 
Posts: 1
Joined: Mon Sep 05, 2011 4:01 am

Return to Basis

Who is online

Users browsing this forum: No registered users and 5 guests





loading...


This website is not affiliated with, sponsored by, or approved by SAP AG.