This website is not affiliated with, sponsored by, or approved by SAP AG.

Content Error connection error

Basis (Basis Technology Modules: Basis Component/System Administration, GUIs)

Moderators: Snowy, thx4allthefish

Content Error connection error

Postby MistralLara » Thu May 20, 2010 2:45 am

Hi All

I have installed Content Sever 6.40 on AIX 5.3 and MaxDB 7.6.0. I have created connection to ERP system, but when I test this connection using RSCMST report, I have this error message:

Connection to http://sapdcns-lpar:1090/ContentServer/ContentServ: Document does not contain any data

RSCMSTH0
HTTP interface test using function group SFTP. Test fails

RSCMSTH1
HTTP interface test using function group SCMS_HTTP. Test is Correct

RSCMSTH2
HTTP interface test using function group SCMS_HTTP (docProt). Test fails

RSCMSTH3
HTTP interface test using function group SCMS_HTTP (mCreate). Test fails

RSCMSTA0
Interface test using function group SCMS-API. Test fails

RSCMSTAC
Interface test using function group SCMS_API (caching). Test fails

RSCMSTAT
Interface test using function group SCMS_API/SCMS_TR (transport). Test fails

RSCMSTHS
HTTP Interface Test (SAP Content Server). Test is correct

Someone could solve it? Some idea?

Thanks in advanced

Cheers
MistralLara
 
Posts: 489
Joined: Fri Nov 08, 2002 7:35 am

Re: Content Error connection error

Postby thx4allthefish » Thu May 20, 2010 3:42 am

Could be anywhere ...

... try to narrow the error-source down using this checklist.

Come back here when you can pinpoint the error down a bit.
curiousorange wrote:I give up. Humanity isn't worth saving. Why is there never a Vogon Constructor Fleet around when you really need one?
thx4allthefish
 
Posts: 5694
Joined: Sat Oct 26, 2002 6:18 pm
Location: barolo barrel

Re: Content Error connection error

Postby MistralLara » Thu May 20, 2010 10:28 pm

Thanks Fish

I have followed your check list. All is correct. I have activated SMICM trace and this is the the result of dev_http file

[1200378] 893 Bytes sent in 1 ms: 893 KB/s
[1200378] Timeout value: 2000 s
[1200378] Response Header:
[1200378] HTTP/1.1 200 OK#
[1200378] Date: Thu, 20 May 2010 15:16:13 GMT#
[1200378] Server: Apache/2.0.63 (Unix) SAPCS/640 DAV/2#
[1200378] Content-Length: 1096#
[1200378] X-ServerTime: 15:16:13#
[1200378] X-Query: adminContRep&operation=statGet&authId=CN%
3DDECSSFHTTPcontentServer,OU%3DI0020511540,OU%3DSAPWebAS,O%
3DSAPTrustCommunity,C%3DDE&expiration=20100520171619&secKey=xxxxxxX-ServerDate: 2010-05-20#
[1200378] X-pVersion: 0046#
[1200378] X-ServerId: server="xx.xx.xx.109";serverPort="1090"#
[1200378] X-ServerType: SAP HTTP Content Server#
[1200378] Connection: close#
[1200378] Content-Type: text/plain#
[1200378] #
[1200378] 2214 Bytes received in 27 ms: 82 KB/s
[1200378] elapsed time 18259 ms - active time 15157 ms - wait time
15131 ms
[1200378] Rfc call HTTP_GET end
[1200378] elapsed time 18370 ms - active time 15157 ms - wait time
15131 ms
[1200378] SAPHTTP end
[495808] elapsed time 366800 ms - active time 30195 ms - wait time
30164 ms
[495808] SAPHTTP end
[1003734] Response Header:
[1003734] HTTP/1.1 500 Internal Server Error#
[1003734] Date: Thu, 20 May 2010 15:16:10 GMT#
[1003734] Server: Apache/2.0.63 (Unix) SAPCS/640 DAV/2#
[1003734] Content-Length: 1249#
[1003734] X-ServerTime: 15:16:10#
[1003734] X-Query:
get&pVersion=0046&contRep=YSHIFT_REPORT&docId=4BF4E64FB776008AE10080000A3A2D66&compId=data&accessMode=r&authId=CN%3DDECSSFHTTPcontentServer,OU%
3DI0020511540,OU%3DSAPWebAS,O
[1003734] X-ServerDate: 2010-05-20#
[1003734] X-pVersion: 0046#
[1003734] X-ErrorDescription: Cannot start Document request, reason:
SQLConnect failed, [SAP AG][LIBSQLOD SO][MaxDB] Unable to connect to
data source;-709 CONNECT: (connection refused: x_serv
[1003734] X-ServerId: server="xx.xx.xx.109";serverPort="1090"#
[1003734] X-ServerType: SAP HTTP Content Server#
[1003734] Connection: close#
[1003734] Content-Type: text/plain#
[1003734] #
[1003734] 2671 Bytes received in 15107 ms: 0 KB/s
[1003734] elapsed time 334074 ms - active time 332420 ms - wait time
332104 ms
[1003734] Rfc call HTTP_GET end
[1003734] elapsed time 334086 ms - active time 332420 ms - wait time
332104 ms
[1003734] SAPHTTP end


It seems some problem with the database connection. Database is online, and I can connect to it using database manager gui.


Cheers
MistralLara
 
Posts: 489
Joined: Fri Nov 08, 2002 7:35 am

Re: Content Error connection error

Postby thx4allthefish » Thu May 20, 2010 11:44 pm

in CSADMIN, tabstrip 'Settings' there are DB-parameters - check on the settings:

ContentStorageHost ------- localhost
Storage ------- ContentStorage.dll (or the equivalent on AIX)
Security ------- 1 (this is important - it will allow you a password-free login, which is o.k. if you have certificate driven connection via STRUST).
driver ------- MaxDB (caution: the default setting here is something other: livecache)
curiousorange wrote:I give up. Humanity isn't worth saving. Why is there never a Vogon Constructor Fleet around when you really need one?
thx4allthefish
 
Posts: 5694
Joined: Sat Oct 26, 2002 6:18 pm
Location: barolo barrel

Re: Content Error connection error

Postby MistralLara » Fri May 21, 2010 1:15 am

It is needed to install MaxDb client in our ERP system?

I have installed Content Server and MaxDB in a different server, and I don't if I have to install MaxDb client in ERP server.

Repository is running in CSADMIN

These are the settings

ContentStorageHost sapdcns-lpar
ContentStorageName CSD
Storage ContentStorage.dll
Security 0
ContRepDescription Repository for shift reports
DefaultDocProt

Cheers
MistralLara
 
Posts: 489
Joined: Fri Nov 08, 2002 7:35 am

Re: Content Error connection error

Postby thx4allthefish » Fri May 21, 2010 4:13 am

set security to 1 and driver to MaxDB ...
curiousorange wrote:I give up. Humanity isn't worth saving. Why is there never a Vogon Constructor Fleet around when you really need one?
thx4allthefish
 
Posts: 5694
Joined: Sat Oct 26, 2002 6:18 pm
Location: barolo barrel

Re: Content Error connection error

Postby MistralLara » Fri May 21, 2010 7:22 am

Fish, I don't understand you about driver to MaxDB ...
Can you explain me it?

Thanks

Cheers
MistralLara
 
Posts: 489
Joined: Fri Nov 08, 2002 7:35 am

Re: Content Error connection error

Postby MistralLara » Fri May 21, 2010 7:25 am

I have changed security to 1, but errors from RSCMST check are the same...

:cry:
MistralLara
 
Posts: 489
Joined: Fri Nov 08, 2002 7:35 am

Re: Content Error connection error

Postby thx4allthefish » Mon May 24, 2010 10:56 pm

MistralLara wrote:Fish, I don't understand you about driver to MaxDB ...
Can you explain me it?

Thanks

Cheers


In tx. CSADMIN, tabstrip 'settings' (same place where you set 'Security' to 1 add a line with the parameter:

driver (lowercase letters)

and set it to value

MaxDB
curiousorange wrote:I give up. Humanity isn't worth saving. Why is there never a Vogon Constructor Fleet around when you really need one?
thx4allthefish
 
Posts: 5694
Joined: Sat Oct 26, 2002 6:18 pm
Location: barolo barrel

Re: Content Error connection error

Postby MistralLara » Thu May 27, 2010 6:01 am

Hi

These are my settings

ContentStorageHost sapdcns-lpar
ContentStorageName CSD
Storage ContentStorage.dll
Security 1
ContRepDescription Repository for shift reports
DefaultDocProt
driver MaxDB

But the error remains

Connection to http://sapdcns-lpar:1090/ContentServer/ContentServ: Document does not contain any data


CHEERS
MistralLara
 
Posts: 489
Joined: Fri Nov 08, 2002 7:35 am

Re: Content Error connection error

Postby thx4allthefish » Thu May 27, 2010 6:12 am

do you still get the same error on dev_http:

HTTP/1.1 500 Internal Server Error


:?:

Snowy, please correct me - but isn't that a ASP.NET error = something MicroSoftish??
curiousorange wrote:I give up. Humanity isn't worth saving. Why is there never a Vogon Constructor Fleet around when you really need one?
thx4allthefish
 
Posts: 5694
Joined: Sat Oct 26, 2002 6:18 pm
Location: barolo barrel

Re: Content Error connection error

Postby Snowy » Thu May 27, 2010 9:39 am

it is a generic HTTP server error. it can come from any web server (microsoft, SAP, apache or anything else)
SapFans Moderator

Search: http://www.sapfans.com/forums/search.php
Notes: http://service.sap.com/notes
Help: http://help.sap.com
Rules: http://www.sapfans.com/forums/viewtopic.php?t=344127
Snowy
 
Posts: 28767
Joined: Mon Oct 21, 2002 2:33 pm
Location: 3.1415926535

Re: Content Error connection error

Postby MistralLara » Fri May 28, 2010 12:51 am

Hi

Current dev_http file is

---------------------------------------------------
trc file: "dev_http", trc level: 2, release: "700"
---------------------------------------------------
Fri May 28 09:35:29 2010
[467046] sccsid: @(#) $Id: //bas/700_REL/src/krn/ftp/http.c#24 $ SAP
[467046] HTTP Start : argc - 6 a0 - /usr/sap/DEC/DVEBMGS00/exe/saphttp
[467046] sapdec00 sapgw00 04314396 CPIC_TRACE=2 IDX=2
[467046] Rfc call HTTP_GET start

[467046] Connected to sapdcns-lpar Port 1090 in 0 ms
[467046] Request Data:

[467046] GET /ContentServer/ContentServer.dll?info&pVersion=0046&contRep=YSHIFT_REPORT&docId=4BFF41B34482007CE10080000A3A2D66&accessMode=r&a
uthId=CN%3DDECSSFHTTPcontentServer,OU%3DI0020511540,OU%3DSAPWebAS,O%3DSAPTrustCommunity,C%3DDE&expiration=20100528093529&secKey=MIIBwQYJKoZI
hvcNAQcCoIIBsjCCAa4CAQExCzAJBgUrDgMCGgUAMAsGCSqGSIb3DQEHATGCAY0wggGJAgEBMIGHMHwxCzAJBgNVBAYTAkRFMRwwGgYDVQQKExNTQVAgVHJ1c3QgQ29tbXVuaXR5MRMw
EQYDVQQLEwpTQVAgV2ViIEFTMRQwEgYDVQQLEwtJMDAyMDUxMTU0MDEkMCIGA1UEAxMbREVDIFNTRiBIVFRQIGNvbnRlbnQgU2VydmVyAgcgEAUQEjhGMAkGBSsOAwIaBQCgXTAYBgkq
hkiG9w0BCQMxCwYJKoZIhvcNAQcBMBwGCSqGSIb3DQEJBTEPFw0xMDA1MjgwNzM1MjlaMCMGCSqGSIb3DQEJBDEWBBTU3fIc9zkLA29bYNd58mNv4qDdKjANBgkqhkiG9w0BAQEFAASB
gFxt20C%2FYySaMBbhHm9AZghTUAeJqIA3xjTrLN92pzWwntZ4KGt83PcCI0sDFsse%2BCpzdbzpVYAuITQjwXWPIZecdoQam2BQUJcu1FLEdnGiAU9ZCtk6%2BbM5yS%2Bzk3z%2BS4
7RUfl9wq9tKkMUqf%2FijKuw%2FwiMeGLYpqTOsuzMjqPj HTTP/1.0
Host: sapdcns-lpar:1090
Content-Length: 0
User-Agent: SAPHTTP



[467046] 955 Bytes sent in 1 ms: 955 KB/s
[467046] Timeout value: 2000 s
*** ERROR => [467046] No data received. NiError: NIECONN_BROKEN [http.c 2786]
[467046] elapsed time 200 ms - active time 143 ms - wait time 0 ms
[467046] Rfc call HTTP_GET end
[467046] Rfc call HTTP_GET start

HTTP/1.0
Host: sapdcns-lpar:1090
Content-Length: 0
User-Agent: SAPHTTP



[467046] 955 Bytes sent in 1 ms: 955 KB/s
[467046] Timeout value: 2000 s
*** ERROR => [467046] No data received. NiError: NIECONN_BROKEN [http.c 2786]
[467046] elapsed time 200 ms - active time 143 ms - wait time 0 ms
[467046] Rfc call HTTP_GET end
[467046] Rfc call HTTP_GET start

[467046] Connected to sapdcns-lpar Port 1090 in 1 ms
[467046] Request Data:

[467046] GET /ContentServer/ContentServer.dll?serverInfo&pVersion=0046&contRep=YSHIFT_REPORT HTTP/1.0
Host: sapdcns-lpar:1090
Content-Length: 0
User-Agent: SAPHTTP



[467046] 161 Bytes sent in 1 ms: 161 KB/s
[467046] Timeout value: 2000 s
[467046] Response Header:

[467046] HTTP/1.1 200 OK


[467046] Date: Fri, 28 May 2010 07:35:25 GMT
[467046] Server: Apache/2.0.52 (Unix) SAPCS/640 DAV/2
[467046] GET /ContentServer/ContentServer.dll?serverInfo&pVersion=0046&contRep=YSHIFT_REPORT HTTP/1.0
Host: sapdcns-lpar:1090
Content-Length: 0
User-Agent: SAPHTTP



[467046] 161 Bytes sent in 1 ms: 161 KB/s
[467046] Timeout value: 2000 s
[467046] Response Header:

[467046] HTTP/1.1 200 OK


[467046] Date: Fri, 28 May 2010 07:35:25 GMT
[467046] Server: Apache/2.0.52 (Unix) SAPCS/640 DAV/2
[467046] Content-Length: 573
[467046] X-ServerTime: 07:35:25
[467046] X-Query: serverInfo&pVersion=0046&contRep=YSHIFT_REPORT
[467046] X-ServerDate: 2010-05-28
[467046] X-pVersion: 0046
[467046] X-ServerId: server="10.58.45.109";serverPort="1090"
[467046] X-ServerType: SAP HTTP Content Server
[467046] Connection: close
[467046] Content-Type: text/plain; charset=ISO-8859-1
[467046]
[467046] 978 Bytes received in 47 ms: 20 KB/s

[467046] elapsed time 2095 ms - active time 201 ms - wait time 47 ms
[467046] Rfc call HTTP_GET end
[467046] elapsed time 2251 ms - active time 201 ms - wait time 47 ms
[467046] SAPHTTP end

Cheers
MistralLara
 
Posts: 489
Joined: Fri Nov 08, 2002 7:35 am

Re: Content Error connection error

Postby thx4allthefish » Fri May 28, 2010 1:10 am

this no longer a http-error.

check your firewall settings -> niecon usually points to the network and most likely the firewall.
curiousorange wrote:I give up. Humanity isn't worth saving. Why is there never a Vogon Constructor Fleet around when you really need one?
thx4allthefish
 
Posts: 5694
Joined: Sat Oct 26, 2002 6:18 pm
Location: barolo barrel

Re: Content Error connection error

Postby MistralLara » Fri May 28, 2010 7:02 am

Hi again

When the errors happens, a core is created

If you debug the core file:

dbx -C ../core
Type 'help' for help.
[Object file is not specified. Using "httpd" as an object file]
warning: The core file is not a fullcore. Some info may
not be available.
[using memory image in ../core]
reading symbolic information ...

Segmentation fault in sig_coredump at line 955 in
file "/home/csdcs/httpd-2.0.52/server/mpm_common.c"
955 kill(getpid(), sig);

It seems some problem with Apache ??

Cheers
MistralLara
 
Posts: 489
Joined: Fri Nov 08, 2002 7:35 am

Next

Return to Basis

Who is online

Users browsing this forum: Google Adsense [Bot] and 7 guests





loading...


This website is not affiliated with, sponsored by, or approved by SAP AG.