Page 1 of 1

cost centre issue while Hiring Action

PostPosted: Tue Apr 22, 2014 3:45 am
by majids71
Hi,

When I hire an employee though an action, it gives me an error in Infotye 0001 - Please maintain cost centre. I have not assigned any cost centre to the Org Unit or Position.

I do not want the system to check the cost centre assignment and hence give no error but let the hiring happen without any issues.

What do I need to do for the system to overlook the cost centre assignment temporarily for uploading the hiring data and then get it back on in future.

Thanks & regards,
Majid

Re: cost centre issue while Hiring Action

PostPosted: Fri Aug 08, 2014 10:21 am
by ljgershman
Hi Majid,

The Cost Center field on IT0001 may be set as RF (Required Field) in table T588M, module pool MP000100. I suggest checking table T588M, module pool MP000100 for the specific screen number and Variable key that applies to your hire transaction (usually by country). If field P0001-KOSTL is RF, you may need to change it to OF (Optional Field). This will allow the field to be populated when a cost center defaults from the org unit or position and also allows it to be blank. But keep in mind that since it does not require a cost center, it would allow the field to be blank when a cost center may actually be needed. My client set the cost center field as required. But we also created a variable key '99' which makes cost center optional and linked it to a user group '99' in feature P0001. The user can change their user group to '99' in their profile (SU3) and then run the hire action and leave cost center blank for times when a cost center is not required during a hiring action.

Thanks,
Larry